LucidLink Classic Service Outage

Incident Report for LucidLink

Resolved

Our team has confirmed the issue with the discovery service for Classic filespaces is fully resolved. If you continue to experience any problems, please open a support ticket at https://support.lucidlink.com/. Thanks for your patience during this incident!
Posted Sep 02, 2025 - 18:47 UTC

Monitoring

We've identified the issue and applied a fix. We're now monitoring the service to ensure full recovery.
Posted Sep 02, 2025 - 13:39 UTC

Investigating

We are currently investigating an outage affecting the discovery service for Classic filespaces. Users may be unable to connect to their filespaces. We are actively working to restore service and will provide updates as more information becomes available.
Posted Sep 02, 2025 - 13:23 UTC
This incident affected: LucidLink (North America), LucidLink (Latin America), LucidLink (Asia-Pacific), and LucidLink (Europe).