AWS outage impacting LucidLink

Incident Report for LucidLink

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:37 UTC

Monitoring

Earlier today, a major outage in the AWS US-EAST-1 region temporarily affected parts of LucidLink’s Classic environment.
For about 30–35 minutes, some Classic users may have been unable to log in to their filespaces.
No data or connected users were affected: Anyone already logged in remained fully connected and continued working without interruption.
No performance degradation was observed or reported on the new LucidLink: all systems continue to operate normally.
Thanks for your patience while we worked through today’s AWS outage. Service is fully restored and running as expected.
Posted Oct 20, 2025 - 10:43 UTC

Identified

Amazon Web Services (AWS) is currently experiencing a major outage in the US-EAST-1 region.
This global AWS issue is causing increased error rates and latency across multiple AWS services, which may impact access to LucidLink for some users.
Our engineering and operations teams are actively monitoring the situation and working closely with AWS to restore normal performance as soon as possible.
We’ll continue to share updates as AWS provides more information.
Thank you for your patience. We know how critical uptime is for your workflows, and we’re doing everything possible to minimize disruption.
Posted Oct 20, 2025 - 09:54 UTC
This incident affected: LucidLink (North America), LucidLink (Latin America), LucidLink (Asia-Pacific), and LucidLink (Europe).