IBM connectivity issues

Incident Report for LucidLink

Resolved

The issue affecting our customers using IBM storage has been resolved. If you experience any issues with your IBM storage, please reach out to our Support Team.
Posted Jun 05, 2025 - 06:09 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 04, 2025 - 15:05 UTC

Monitoring

IBM has restored the affected services, and the issue should be resolved. If you still experience issues with your filespace, please reach out to our Support Team!
Posted Jun 04, 2025 - 14:20 UTC

Identified

IBM has identified the cause of the issue, and their team is working to recover the service.
Posted Jun 04, 2025 - 13:23 UTC

Update

IBM is continuing to investigate this issue.
Posted Jun 04, 2025 - 11:26 UTC

Update

IBM has confirmed an outage on their end. For more information, you can visit the IBM status page (https://cloud.ibm.com/status/) and look for the following incident: INC9185853
Posted Jun 04, 2025 - 11:06 UTC

Investigating

Customers with IBM filespaces are experiencing degraded performance since 10:30 AM UTC on the 4th of June, 2025.
We are in contact with IBM and will update the status page upon progress.
Posted Jun 04, 2025 - 10:49 UTC
This incident affected: LucidLink (North America), LucidLink (Latin America), LucidLink (Asia-Pacific), and LucidLink (Europe).